Unsupported Screen Size: The viewport size is too small for the theme to render properly.

Scheduled Backup Not Working Using Ssh

forums forums SQLyog Sync tools, Migration, Scheduled Backup and Notifications Scheduled Backup Not Working Using Ssh

This topic contains 0 replies, has 0 voices, and was last updated by  Sibin A S 1 year, 1 month ago.

  • Author
    Posts
  • #13563

    JohnS
    Member

    Until now I have been accessing databases using the wildcard %, however my host recently closed wildcard access and I now have to access using SSH.

    SQLyog works fine with SSH in the GUI and I can access the database.

    When I use the wizard to set up the backup in the first screen I select to use an existing connection which it accepts and lets me select the database required on the server.

    However the scheduled backup always fails with the message

    ERROR: 2003 Can’t connect to MySQL server on ‘localhost’ (0) Error in connection.

    Same happens when I run the task from Scheduled Jobs.

     

    I have tried deleting all the files (connection profile and sja tasks) and creating again from the wizard, but that makes no difference.

     

    The strange thing is that I can set up another profile to a different server/domain and SSH works fine for scheduled backups.

     

    Could this be a server issue, though I can’t see why if the GUI works ok with that profile why the scheduled backup should not work.

     

    I am attaching a copy of the xml file created by the wizard, I have masked the sensitive information.

     

    Thanks

     

     

     

     

     

     

     

  • #35777

    Sibin A S
    Moderator

    Hello,

     

    This seems to be a server issue as SQLyog is not able to connect to the respective server. Any client connecting from same host with same connection details would face the same problem. 

     

    You may refer our FAQ that lists the reasons for this error, here >> http://faq.webyog.com/content/23/15/en/error-no-2003-can_t-connect.html

     

    Please check for “skip_networking” and “bind_address” settings in MySQL configuration of the server that does not connect. 

     

    Regards,

    Sibin

You must be logged in to reply to this topic.