Unsupported Screen Size: The viewport size is too small for the theme to render properly.

Rebuilding Tag Files

forums forums SQLyog SQLyog: Bugs / Feature Requests Rebuilding Tag Files

  • This topic is empty.
Viewing 5 reply threads
  • Author
    • #12502

      Odd enough I cannot find any nifo on it in the help file, I can't search it on the forum because 'tag' has only 3 letters, and Googling didn't help me either, so…here goes:

      I just upgraded from a very old version of SQLYog to the most recent on, and while I was looking at a table on my remote webserver, and clicked to sort by id DESC, everything froze and I got the “Rebuilding tag files” message in the lower left corner.

      Not only is this taking quite some time now, it also completely halted MySQLand each and every website I host there is now unreachable.

      So, 2 questions:

      1. What the hey are tag files, and why is SQLYog rebuilding them?

      2. How do I interrupt this?


    • #32842

      OK, panic mode off…restarting MySQL didn't work, so I rebooted the server. Also found the Autocomplete options in the settings, and turned it off.

      Maybe add a dialog to that rebuilding, explaining that it may take a very lnog time on larger databases and that the entire MySQL instance will be doing nothing else during that time -> “Are you sure you want to rebuild the tag files?”

    • #32843

      “and that the entire MySQL instance will be doing nothing else during that time”. Did you really experience this? Autocomplete just executes very basic and inexpensive SHOW statements. We do not access data and do not LOCK in any way.

      Also sorting does not neither start or stop 'rebuilding tags'. If the interncase 'froxe' it is simply because the server takes that time to return data (in DATA tab we sort by sending a SELCT .. ORDER BY – in RESULT tab we sort in the internal SQLyog buffer). As long as teh data have not been received the actual conenction tab of SQLyog is in 'wait mode'. it cannot be otherwise with the MySQL client/server protocol.

      Can you explain exactly how to reproduce the problem? And please do not make any assumptions (I really do not belive that your assumption that this is related to autocomplete holds water).

    • #32844

      Hello Peter,

      I had just installed the new version, and was looking at a table in the data-tab (a phpbb_posts table containing 45K records). I wanted to see the most recent posts, so I clicked the id column header (sort asc), and then clicked it again to sort desc – something I do quite frequently, and which has never ever caused any problems. At the moment I did that my client froze with the data still in asc order, and the message “Rebuilding tag files” in the status bar. I waited a minute or so while nothing continued to happen, and then tried to close the client. This didn't work because I got the message that SQLYog couldn't close because a query was being executed.

      Being somewhat impatient I opened the old version of the client to be able to check those posts while the new client did what it needed to do, and that's when I found out that the server wasn't responding. I checked my webserver, and the MySQL service processor usage was 0-1%, so the server instance wasn't working like mad.

      I then opened one of my websites and noticed it didn't display because it couldn't open any databases.

      I tried to restart the MySQL service, but that hung on 'Stopping'. The new client had been disconnected, so it was responsive again. After waiting some more to see if the service would restart whilst answering my customers why their websites weren't responding I decided to reboot the server alltogether, which worked.

      So, while not wanting to make assumptions, I do get the very strong impression that the rebuilding of tag files has something to with it – maybe because it started rebuilding at the exact moment I clicked the id column header. After disabling autocomplete this has not happened again, and I'm not going to re-enable it because I don't want anymore downtime on those websites.

    • #32845

      OK .. let us check tomorrow if we can reproduce it somehow.

      Anyway .. in between could you please try with 9.33 that was released moments ago. Refer:


    • #32846

      Like I said: after disabling autocomplete the problem has not resurfaced, and I'm not going to re-enable it because I don't want to risk getting angry customers on the phone again.

      As far as I'm concerned the problem is resolved by disabling autocomplete (which I don't want or need anyway). In my first post I was looking for this solution, and in my second I let you know I found it. I'm more than happy to explain what happened exactly but I'm not going to test a new release with the risk of it happening again. Sorry.

Viewing 5 reply threads
  • You must be logged in to reply to this topic.