Unsupported Screen Size: The viewport size is too small for the theme to render properly.

Monyog & Utf8

forums forums Monyog Monyog Deployment Monyog & Utf8

  • This topic is empty.
Viewing 2 reply threads
  • Author
    Posts
    • #13578
      simonh
      Member

      Hi all,

       I’m just trying out monyog on the test installation.

       

      I can connect to many of our mysql/mariadb servers but we have a few where the default characters sets are utf8mb4. If I try and connect to them, the connection fails with the error:


      Failed to connect to MySQL: Can't initialize character set unknown (path: compiled_in)

      Does anyone know if there’s a solution to this – I’ve done some googling and searching in this forum but couldn’t see anything.

       

      This is the monyog trial .tar.gz downloaded today and running on Centos 7 linux

       

      Thanks

    • #35817
      saksham_ahuja
      Participant

      Hello,

       

       

      We tried reproducing the issue, but MONyog successfully connected to the server where default characters sets are utf8mb4. If you are still facing this issue, please create a support ticket at support@webyog.com and provide us with the following :

       

      1. The screenshot of the MySQL settings in MONyog after clicking on ‘Test Settings’ button.

      2. The output of the following queries from one of the MySQL servers where you are getting this error while registering on MONyog : 

       

          show variables like ‘%collation%’;

          show variables like ‘%character%’;

       

       

      Regards,

      Saksham Ahuja

      Team MONyog.

    • #35818
      simonh
      Member

      Saksham,

       I’ve attached a screenshot as requested

       

      [attachment=2082:monyog.jpg]

       

      Here are the results from the queries you requested:

       


      MariaDB [(none)]> show variables like '%collation%';
      +
      +
      +
      | Variable_name        | Value                  |
      +
      +
      +
      | collation_connection | utf8_general_ci        |
      | collation_database   | utf8mb4_unicode_520_ci |
      | collation_server     | utf8mb4_unicode_520_ci |
      +
      +
      +
      3 rows in set (0.00 sec)


      MariaDB [(none)]> show variables like '%character%';
      +
      +
      +
      | Variable_name            | Value                      |
      +
      +
      +
      | character_set_client     | utf8                       |
      | character_set_connection | utf8                       |
      | character_set_database   | utf8mb4                    |
      | character_set_filesystem | binary                     |
      | character_set_results    | utf8                       |
      | character_set_server     | utf8mb4                    |
      | character_set_system     | utf8                       |
      | character_sets_dir       | /usr/share/mysql/charsets/ |
      +
      +
      +
      8 rows in set (0.00 sec)

       

       

Viewing 2 reply threads
  • You must be logged in to reply to this topic.