Unsupported Screen Size: The viewport size is too small for the theme to render properly.

Monyog-bin Is Running But Cannot Connect To Dashboard

forums forums Monyog Monyog Deployment Monyog-bin Is Running But Cannot Connect To Dashboard

  • This topic is empty.
Viewing 0 reply threads
  • Author
    Posts
    • #13270
      audetweb
      Member

      I am a new client testing out MONyog on a CentOS 6.6.4 VPS on the Jelastic cloud platform.

       

      I am running the trial version and I do not have a license number in the MONyog config file.

       

      The installation using RPM worked and the binary is running as a process.

       

      [[email protected] ~]# netstat -lnp

      Active Internet connections (only servers)

      Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name

      tcp        0      0 0.0.0.0:5555                0.0.0.0:*                   LISTEN      826/MONyog-bin

       

      [[email protected] ~]# lsof -i :5555

      COMMAND   PID USER   FD   TYPE    DEVICE SIZE/OFF NODE NAME

      MONyog-bi 826 root   11u  IPv4 618066714      0t0  TCP *:personal-agent (LISTEN)

       

      However, when I go to my web browser and type in the URL, I cannot connect:

       

      http://aaa.bbb.ccc.ddd:5555

       

      I get the following error message from Firefox:

       

      The connection has timed out

      The server at aaa.bbb.ccc.ddd is taking too long to respond.

       

      I also checked the iptables:

       

      [[email protected] ~]# cat /etc/sysconfig/iptables

      # Generated by iptables-save v1.4.7 on Thu Oct 23 01:38:58 2014

      *nat

      :PREROUTING ACCEPT [25:1213]

      :POSTROUTING ACCEPT [3:200]

      :OUTPUT ACCEPT [3:200]

      COMMIT

      # Completed on Thu Oct 23 01:38:58 2014

      # Generated by iptables-save v1.4.7 on Thu Oct 23 01:38:58 2014

      *filter

      :INPUT DROP [0:0]

      :FORWARD DROP [0:0]

      :OUTPUT ACCEPT [6:752]

      -A INPUT -i lo -j ACCEPT

      -A INPUT -m state –state RELATED,ESTABLISHED -j ACCEPT

      -A INPUT -p tcp -m tcp –dport 22 -m state –state NEW -j ACCEPT

      -A INPUT -p tcp -m tcp -m multiport –dports 80,443,8080,8022 -m state –state NEW -j ACCEPT

      -A INPUT -j REJECT –reject-with icmp-host-prohibited

      -A INPUT -p tcp -m tcp –dport 5555 -m state –state NEW -j ACCEPT

      -A OUTPUT -p tcp -m tcp –dport 5555 -j ACCEPT

      COMMIT

      # Completed on Thu Oct 23 01:38:58 2014

      # Generated by iptables-save v1.4.7 on Thu Oct 23 01:38:58 2014

      *mangle

      :PREROUTING ACCEPT [265:19849]

      :INPUT ACCEPT [265:19849]

      :FORWARD ACCEPT [0:0]

      :OUTPUT ACCEPT [213:29744]

      :POSTROUTING ACCEPT [213:29744]

      COMMIT

      # Completed on Thu Oct 23 01:38:58 2014

       

      I am missing something obvious, like some firewall setting or maybe a bridge.  I am not a Linux expert but I can muddle through the command line.

       

      I see that MONyog is listening on a local address (?) instead of the public IP address, is this right?

      Am I missing a connection between my public IP address and the local LAN address?

       

      Thank you.

       

      UPDATE – Found a Solution

       

      I removed the following two lines from the iptables configuration file:

       

      -A INPUT -p tcp -m tcp –dport 5555 -m state –state NEW -j ACCEPT

      -A OUTPUT -p tcp -m tcp –dport 5555 -j ACCEPT

       

      I then added port 5555 to the list of ports on this line:

       

      -A INPUT -p tcp -m tcp -m multiport –dports 80,443,8080,8022,5555 -m state –state NEW -j ACCEPT

       

      I then restarted the iptables daemon and I was able to pull up the dashboard.

       

      I still need to learn how to configure iptables, otherwise, the problem is solved.

Viewing 0 reply threads
  • You must be logged in to reply to this topic.