Unsupported Screen Size: The viewport size is too small for the theme to render properly.

Issues connecting to MYSQl through SSH with localhost root user

forums forums SQLyog Using SQLyog Issues connecting to MYSQl through SSH with localhost root user

This topic contains 1 reply, has 2 voices, and was last updated by  Sibin A S 1 week, 6 days ago.

  • Author
    Posts
  • #36040

    americanninja
    Participant

    I’m having issues using SQLYog on my PC to connect to my server. I am using the exact same settings on my Mac using the FREE Sequel PRO and it works without any issue.

    I am able to connect through SSH via SQLYog but when it tries to connect to MYSQL it throws back an ERROR NO. 1045 Access denied for user ‘root’@’localhost’ (using password: YES)

    The password IS correct. I noticed if I log into my server via terminal and try to access mysql by doing:
    mysql -u root@localhost -p

    I get the same error message response. I usually connect to mysql server by doing this:
    mysql -u root -p

    So how do I tell sqlyog to NOT include the @localhost, which I assume it’s doing. I am using localhost in the “MySQL Host Address” field, so I assume that’s the issue. However, i can’t leave this field blank.

    On Sequel Pro, I am actually using the server’s public IP address for the mysql host address. Anyway, that tool is working. I would just like to get this working from my PC though.

    Any ideas, what’s the deal with this?

  • #36044

    Sibin A S
    Moderator

    Hi,

    Have you tried using the server’s public IP address as the mysql host address in SQLyog and tried connecting? If yes, do you get any error while connecting?

    You may also refer our FAQ for the error 1045, here.

    Regards,
    Sibin

You must be logged in to reply to this topic.