Unsupported Screen Size: The viewport size is too small for the theme to render properly.

Can Not Change Date ?

forums forums SQLyog SQLyog: Bugs / Feature Requests Can Not Change Date ?

Tagged: 

  • This topic is empty.
Viewing 3 reply threads
  • Author
    Posts
    • #13316
      sky_proj
      Member

      Im use sqlyog v11.33,

      i want try edit date => field “tgbukti” with value = 2015-01-05 and save that its ok, but when i refresh again,  the value still same old value 2015-01-06, can u check what is problem? thx

       

       

      here sample my database:

      =====================

       

      /*

      SQLyog Ultimate v11.33 (32 bit)

      MySQL – 5.1.33-community-log : Database – data3

      *********************************************************************

      */

      /*!40101 SET NAMES utf8 */;

      /*!40101 SET SQL_MODE=”*/;

      /*!40014 SET @[email protected]@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;

      /*!40014 SET @[email protected]@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;

      /*!40101 SET @[email protected]@SQL_MODE, SQL_MODE=’NO_AUTO_VALUE_ON_ZERO’ */;

      /*!40111 SET @[email protected]@SQL_NOTES, SQL_NOTES=0 */;

      CREATE DATABASE /*!32312 IF NOT EXISTS*/`sritex3` /*!40100 DEFAULT CHARACTER SET latin1 */;

      USE `sritex3`;

      /*Table structure for table `faktur1_copy` */

      DROP TABLE IF EXISTS `faktur1_copy`;

      CREATE TABLE `faktur1_copy` (

        `KD_CUST` char(9) NOT NULL DEFAULT ”,

        `NO_FAKTUR` char(20) NOT NULL DEFAULT ”,

        `NO_MP` char(20) NOT NULL DEFAULT ”,

        `TGL_FAKTUR` date NOT NULL DEFAULT ‘0000-00-00’,

        `TGBUKTI` date DEFAULT NULL,

        `TERBAYAR` decimal(18,2) DEFAULT NULL,

        `JUMLAH` decimal(18,2) NOT NULL DEFAULT ‘0.00’,

        `KWANTUM1` decimal(18,3) DEFAULT NULL,

        `KWANTUM2` decimal(18,3) DEFAULT NULL,

        `KETBRG` char(20) NOT NULL DEFAULT ”,

        `SATUAN1` char(3) DEFAULT NULL,

        `SATUAN2` char(3) DEFAULT NULL,

        `KD_BARANG` char(23) NOT NULL DEFAULT ”,

        `NA_BARANG` char(40) DEFAULT NULL,

        `HRG_SAT1` decimal(18,4) DEFAULT NULL,

        `HRG_SAT2` decimal(18,4) DEFAULT NULL,

        `JNKAIN` char(1) DEFAULT NULL,

        `ITEMG` char(2) NOT NULL DEFAULT ”,

        `CUST2` char(9) DEFAULT NULL,

        `CAT` char(15) DEFAULT NULL,

        `LEBAR` decimal(3,0) DEFAULT NULL,

        `KD_KAIN` char(6) DEFAULT NULL,

        `PROSES` char(15) DEFAULT NULL,

        `DEPT` char(6) DEFAULT NULL,

        `USER` char(10) DEFAULT NULL,

        PRIMARY KEY (`ITEMG`,`KETBRG`,`KD_BARANG`,`JUMLAH`,`TGL_FAKTUR`,`NO_MP`,`NO_FAKTUR`,`KD_CUST`)

      ) ENGINE=MyISAM DEFAULT CHARSET=latin1;

      /*Data for the table `faktur1_copy` */

      insert  into `faktur1_copy`(`KD_CUST`,`NO_FAKTUR`,`NO_MP`,`TGL_FAKTUR`,`TGBUKTI`,`TERBAYAR`,`JUMLAH`,`KWANTUM1`,`KWANTUM2`,`KETBRG`,`SATUAN1`,`SATUAN2`,`KD_BARANG`,`NA_BARANG`,`HRG_SAT1`,`HRG_SAT2`,`JNKAIN`,`ITEMG`,`CUST2`,`CAT`,`LEBAR`,`KD_KAIN`,`PROSES`,`DEPT`,`USER`) values (‘J.KAG.001′,’FLJ/GARMT/10087/0115′,”,’2015-01-06′,’2015-01-06′,NULL,’4875305985.00′,’155.000′,NULL,’PJAB0072/21   GM01′,’SET’,NULL,’424510000501′,’IPP SET’,’31453587.0000′,NULL,NULL,”,NULL,NULL,NULL,NULL,NULL,NULL,NULL);

      /*!40101 SET [email protected]_SQL_MODE */;

      /*!40014 SET [email protected]_FOREIGN_KEY_CHECKS */;

      /*!40014 SET [email protected]_UNIQUE_CHECKS */;

      /*!40111 SET [email protected]_SQL_NOTES */;

       

    • #35199
      peterlaursen
      Participant

      Please

       

      1) tell what exactly you do when you save? You will have to either click the save button (the small diskette icon) or move the cursor vertically to another row. Save does not happen when you move the cursor horizontally (to another column/cell in same row)

      2) check in HISTORY tab what UPDATE statement SQLyog sends to the server. 

      3) check in MESSAGES tab of SQLyog for errors or warnings. 

    • #35200
      peterlaursen
      Participant

      Here SQLyog sends the statement 

       

      UPDATE `sritex3`.`faktur1_copy` SET `TGBUKTI` = ‘2015-02-05’ WHERE `KD_CUST` = ‘J.KAG.001’ AND `NO_FAKTUR` = ‘FLJ/GARMT/10087/0115’ AND `NO_MP` = ” AND `TGL_FAKTUR` = ‘2015-01-06’ AND `JUMLAH` = ‘4875305985.00’ AND `KETBRG` = ‘PJAB0072/21   GM01’ AND `KD_BARANG` = ‘424510000501’ AND `ITEMG` = ”; 

      (you have a very complex primary key and that causes the many WHERE conditions)

       

      ..and it works as expected (I tried on MySQL 5.5.41). You may try to execute that statement manually (from any client). If it does not change on the server it is a server bug.  Your server (5.1.33) is rather old now. Refer this FAQ: http://faq.webyog.com/content/1/178/en/sqlyog-is-a-client-for-the-mysql-server-_-but-what-server-versions-are-supported.html.  There were a lot of bugs introduced in MySQL between 5.1.30 and 5.1.35 (but they mostly afffected InnoDB, and you are using MyISAM)
    • #35201
      sky_proj
      Member

      hi Peter Laursen,

       

      i have try this code and worked.. thanks :), here code i have tryed :

      UPDATE `sritex3`.`faktur1_copy` SET `TGBUKTI` = ‘2015-02-05’

      WHERE `NO_FAKTUR` = ‘FLJ/GARMT/10087/0115’

       

      ty

      Hendro

Viewing 3 reply threads
  • You must be logged in to reply to this topic.