Unsupported Screen Size: The viewport size is too small for the theme to render properly.

Error 1045

forums forums SQLyog Using SQLyog Error 1045

Tagged: , ,

This topic contains 2 replies, has 0 voices, and was last updated by  WilandTech 5 years, 4 months ago.

  • Author
    Posts
  • #13071

    WilandTech
    Member

    Hi, I am evaluating your 11.24 version of enterprise and am consistently getting a 1045 error return. I have tried both the 64 bit and 32bit versions and get the same error. I have checked both SSL settings that they are set, and have all keys and certs in place (don't use a cipher) but there is no change. When I use my previous version 10.4.2-0 I can connect without any problems at all.

    We have SSL Enforced on our mysql server, so I can't disable that. We are currently using MYSQL 5.1.71 and have plans to eventually upgrade but will not be doing such at the current time. This is being used on machines running Windows 7 Professional 64bit.

    Also should I be directing these questions to the forums here or using the contact support in the customer login area?

  • #34535

    peterlaursen
    Participant

    We have one more report of this. For the user who reported this this is reproducible on one specific (client) machine only (and not others) and when connecting to one specific server only. We have not been able to reproduce it in our environment.

    MySQL changed their SSL library (from 'openssl' to 'yassl') at some point. I don't record exactly when, but this could be related. And if it is, I think that there are good channes that latest SQLyog will work if you upgrade the server.

    The key to the problem could very well be this “We have SSL Enforced on our mysql server”. Can you elaborate how? Please provide the exact configuration options (in my.cnf/my.ini)

    You are welcome to create a support ticket (sending a mail to support@webyog.com is the easiest way)

  • #34536

    peterlaursen
    Participant

    After checking details I can state that the other report I referred was not exactly this. This was another error and error message.

    Are you perfectly sure that this FAQ : http://faq.webyog.co…ion-denied.html

    .. does not have the explanation?

    If you did not install on same machine you could have entered some details wrong, mismatched keys etc. Please double-check again.

  • #34537

    WilandTech
    Member

    I have opened a support ticket as well.

    We are able to connect to a server just fine when we disable REQUIRE SSL in the user grants in the mysql database. We have REQUIRE SSL turned on for all accounts due to security policies.

    I tried to connect to a 5.6 mysql server and received the same error of 1045 as well.

    I have 10.4.2-0 installed as well, and If i open that and attempt to connect to any database it connects through just fine. We also use 9.35 and 9.33 within our company and those have no problem either.

You must be logged in to reply to this topic.