Jump to content


Photo

Error No. 2003


  • Please log in to reply
7 replies to this topic

#1 numb3rs

numb3rs

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 25 October 2011 - 09:10 AM

Error No. 2003
Can't connect to MySQL Server on'localhost' (10061)

I have MySQL and SQLyog on same machine

Im trying to connect SQLyog to MySQL. Can anyone help me with this

#2 sathish

sathish

    Advanced Member

  • Admin
  • PipPipPip
  • 334 posts
  • Gender:Male

Posted 25 October 2011 - 11:04 AM

Hello,

Please read this FAQ: http://webyog.com/fa..._t-connect.html

Note that this is a *connection* error and not an *authentication* error (ie: not because user or password is wrong).

First you should check for firewall issues and settings in server configurations like 'skip_networking' and 'bind_address'.

Regards,
Sathish

#3 numb3rs

numb3rs

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 25 October 2011 - 04:49 PM

Hello,

Please read this FAQ: http://webyog.com/fa..._t-connect.html

Note that this is a *connection* error and not an *authentication* error (ie: not because user or password is wrong).

First you should check for firewall issues and settings in server configurations like 'skip_networking' and 'bind_address'.

Regards,
Sathish



#4 numb3rs

numb3rs

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 25 October 2011 - 05:47 PM

Sorry repeating post.

I went into my.ini and tried placing a # in front of skip-network and save changes but I was denied access. I went through MySQL folder directory but not by using MySql. If I need to use MySQL can you provide query which would allow me to make the changes needed or access that
my.ini and make the Chang.

#5 numb3rs

numb3rs

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 25 October 2011 - 07:50 PM

How do I get to server configuration?

#6 peterlaursen

peterlaursen

    Advanced Member

  • Admin
  • PipPipPip
  • 7,914 posts
  • Gender:Male
  • Location:Skagen, Denmark
  • Interests:well ... jazz/folk music, photography, chess, nature, ecology, history, bicycling, Highland Malts ... well, Lowland Malts and Cognac too actually :-) just wonder how I get the time to touch a computer! SQLyog and MONyog? no that's not interest, that's BASIC NEEDS simply!

Posted 25 October 2011 - 09:24 PM

'server configuration' and 'my.ini' is the same thing

I f I understand you commented the 'skip-networking' option. Now you are able to *connect* - but not able to *authenticate* . It seems you get another error ' access denied' or 'connection denied'. About this read http://webyog.com/fa...ion-denied.html

"User is not allowed to connect from the actual host. Note that MySQL by default only allows connection from 'localhost'. To specify from where a user may connect SQL wildcards (% and _) can be used. Simply 'someuser@%' means that user 'someuser' may connect from everywhere.". If you are connecting from a remote host and the remote user is not created you will have to do with any client that can connect (mysql command line, PhpMyAdmin or whatever). Or alternativley use SSH- or HTTP-tunneling. With tunneling you technically connect from 'localhost'.


Computers make your grey hair come off ....

Peter Laursen
Webyog

#7 numb3rs

numb3rs

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 25 October 2011 - 10:34 PM

No was not able to comment it out. I went to my MySQL folder....clicked on my.ini (came up as notepad) I put comment in tried to save changes and it said access is denied. So I need to know the correct way to access MySQL configuration. Thanks. I'm a newb.

#8 numb3rs

numb3rs

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 26 October 2011 - 01:02 AM

I used mysql server instance configuration to make changes. Will try to connect




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users