Jump to content


Photo

Dependency Hell


  • Please log in to reply
5 replies to this topic

#1 bluethundr

bluethundr

    Newbie

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Summit, NJ
  • Interests:People, culture, language, food, music... nothing that would interest a parasite like you.

Posted 11 March 2010 - 04:31 PM

Hello,

I am attempting to install MONyog onto CentOS release 5.4 (Final). I run rpm -i MONyog-3.7.2-0.glibc-2.5-42.x86_64.rpm (as root) and see this list of dependencies...

error: Failed dependencies:
        libc.so.6()(64bit) is needed by MONyog-3.7.2-0.x86_64
        libc.so.6(GLIBC_2.2.5)(64bit) is needed by MONyog-3.7.2-0.x86_64
        libc.so.6(GLIBC_2.3)(64bit) is needed by MONyog-3.7.2-0.x86_64
        libcrypt.so.1()(64bit) is needed by MONyog-3.7.2-0.x86_64
        libcrypt.so.1(GLIBC_2.2.5)(64bit) is needed by MONyog-3.7.2-0.x86_64
        libdl.so.2()(64bit) is needed by MONyog-3.7.2-0.x86_64
        libdl.so.2(GLIBC_2.2.5)(64bit) is needed by MONyog-3.7.2-0.x86_64
        libgcc_s.so.1()(64bit) is needed by MONyog-3.7.2-0.x86_64
        libgcc_s.so.1(GCC_3.0)(64bit) is needed by MONyog-3.7.2-0.x86_64
        libm.so.6()(64bit) is needed by MONyog-3.7.2-0.x86_64
        libm.so.6(GLIBC_2.2.5)(64bit) is needed by MONyog-3.7.2-0.x86_64
        libnsl.so.1()(64bit) is needed by MONyog-3.7.2-0.x86_64
        libnss_dns.so.2()(64bit) is needed by MONyog-3.7.2-0.x86_64
        libnss_files.so.2()(64bit) is needed by MONyog-3.7.2-0.x86_64
        libpthread.so.0()(64bit) is needed by MONyog-3.7.2-0.x86_64
        libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by MONyog-3.7.2-0.x86_64
        libpthread.so.0(GLIBC_2.3.2)(64bit) is needed by MONyog-3.7.2-0.x86_64
        libresolv.so.2()(64bit) is needed by MONyog-3.7.2-0.x86_64
        librt.so.1()(64bit) is needed by MONyog-3.7.2-0.x86_64
        librt.so.1(GLIBC_2.2.5)(64bit) is needed by MONyog-3.7.2-0.x86_64
        libstdc++.so.6()(64bit) is needed by MONyog-3.7.2-0.x86_64
        libstdc++.so.6(CXXABI_1.3)(64bit) is needed by MONyog-3.7.2-0.x86_64
        libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by MONyog-3.7.2-0.x86_64
        libz.so.1()(64bit) is needed by MONyog-3.7.2-0.x86_64


I have tried searching for individual packages... (for instance yum search libstdc++.so.6 ) but don't seem to be getting anywhere.... I just realized that I'm on 32 bit CentOS and I am attempting to use a 64 bit rpm. Does anybody know where I can download the 32bit rpm? Is there such a beast? I'm dependency hell.. HELP!! :-)

#2 Sayan Chaliha

Sayan Chaliha

    Advanced Member

  • Members
  • PipPipPip
  • 73 posts
  • Gender:Male
  • Location:Bangalore

Posted 12 March 2010 - 04:00 AM

Hi,

The only dependencies that you seem to be missing are glibc and libstdc++. These are the only two libraries we don't bundle with MONyog, as they are standard C++ runtimes, and available in all Linux repositories. You see the other failed dependencies because all other libraries depend on it.

Try this:
yum install gnu-gcc libstdc++

Regards,

Sayan Chaliha
Webyog, Inc

#3 Sayan Chaliha

Sayan Chaliha

    Advanced Member

  • Members
  • PipPipPip
  • 73 posts
  • Gender:Male
  • Location:Bangalore

Posted 12 March 2010 - 04:02 AM

The version of RPM of MONyog that you are trying to install is actually compiled on a CentOS 5.4 (x86_64) base system with C/C++ runtimes installed!
Regards,

Sayan Chaliha
Webyog, Inc

#4 Sayan Chaliha

Sayan Chaliha

    Advanced Member

  • Members
  • PipPipPip
  • 73 posts
  • Gender:Male
  • Location:Bangalore

Posted 12 March 2010 - 04:06 AM

The version of RPM of MONyog that you are trying to install is actually compiled on a CentOS 5.4 (x86_64) base system with C/C++ runtimes installed!



PS: I just noticed you tried to install a 64-bit RPM on a 32-bit system. Here's the link to the 32-bit binary:
http://www.webyog.co...2.5-42.i386.rpm
Regards,

Sayan Chaliha
Webyog, Inc

#5 bluethundr

bluethundr

    Newbie

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Summit, NJ
  • Interests:People, culture, language, food, music... nothing that would interest a parasite like you.

Posted 12 March 2010 - 06:33 PM

That worked!!! Thanks for the link! Is SQLog available for Linux? I only saw a windows binary..

thanks again

#6 Sayan Chaliha

Sayan Chaliha

    Advanced Member

  • Members
  • PipPipPip
  • 73 posts
  • Gender:Male
  • Location:Bangalore

Posted 14 March 2010 - 02:02 PM

Unfortunately, SQLyog is only available for Windows. However, you can still use SQLyog's Job Agent (SJA) on Linux. Moreover, you might want to take a look at Wine... Wine make running Windows software on Linux a breeze.

Also, I was wondering if you have any feedback on the downloads page. We recently had it changed and lots of people seem to be getting confused...

Thanks for your interest in our products!
Regards,

Sayan Chaliha
Webyog, Inc




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users