Jump to content


Photo

Error Code: 2006 - Mysql Server Has Gone Away


  • Please log in to reply
2 replies to this topic

#1 jack111

jack111

    Member

  • Members
  • PipPip
  • 22 posts

Posted 11 May 2007 - 12:06 PM

Have mysql 5 , apache2 and php5 set up as localhost on a windows xp pro machine.

have backed up databases as sql dump from remote servers using sqlyog. I want to get the sites runing on localhost thus trying to restore the sql dumps on the localhost mysql database. sql connects ok but after about 10 seconds get the error

Error Code: 2006 - MySQL server has gone away


Why is this.

the servers I have backed up from are also runing mysql five.

#2 peterlaursen

peterlaursen

    Advanced Member

  • Admin
  • PipPipPip
  • 7,914 posts
  • Gender:Male
  • Location:Skagen, Denmark
  • Interests:well ... jazz/folk music, photography, chess, nature, ecology, history, bicycling, Highland Malts ... well, Lowland Malts and Cognac too actually :-) just wonder how I get the time to touch a computer! SQLyog and MONyog? no that's not interest, that's BASIC NEEDS simply!

Posted 11 May 2007 - 02:20 PM

"Error Code: 2006 - MySQL server has gone away"

I think the most likely reason is that the (server) max_allowed_packet setting is too low compared to the size of BULK inserts in the file.

Old server versions dispaly only that in this situation.  5.0.41 say "got a package too big" or something like that!
Computers make your grey hair come off ....

Peter Laursen
Webyog

#3 jack111

jack111

    Member

  • Members
  • PipPip
  • 22 posts

Posted 11 May 2007 - 06:55 PM

"Error Code: 2006 - MySQL server has gone away"

I think the most likely reason is that the (server) max_allowed_packet setting is too low compared to the size of BULK inserts in the file.

Old server versions dispaly only that in this situation. 5.0.41 say "got a package too big" or something like that!


Thanks that was exactly the problem. Followed the instructions below

http://dev.mysql.com...-too-large.html

In Linux:

Copy the my-xxx.cnf file from /usr/share/mysql to /etc as my.cnf

xxx can be small, medium, large, huge ... depending on the requirement.

$ cp /usr/share/mysql/my-xxx.cnf /etc/my.cnf

In the my.cnf file, change the default
max_allowed_packet = 1M
to
max_allowed_packet = 16M

Save the file and restart MySQL server.

In Windows:

In the MySQL server installation directory,
in my.ini file, add the following line under [mysqld] in SERVER SECTION.

max_allowed_packet = 16M

Save the file and restart MySQL server.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users